Willkommen auf Planet-Liebe

diskutiere über Liebe, Sex und Leidenschaft und werde Teil einer spannenden Community! :)

jetzt registrieren

PHP-Problem

Dieses Thema im Forum "Musik, Filme, Computer und andere Medien" wurde erstellt von BenNation, 22 April 2008.

  1. BenNation
    BenNation (33)
    Meistens hier zu finden
    1.225
    133
    74
    vergeben und glücklich
    Ich habe eine Script-Datei namens nametest.php, in der steht folgendes:
    Jetzt hab ich die auf unseren Schulserver geladen (der hat PHP) und mit [..]/nametest.php?user=Ben aufgerufen. Nur kommt nix dabei raus. Es erscheint nur
    Vom $user keine Spur. Was mach ich falsch?
     
    #1
    BenNation, 22 April 2008
  2. Kiya_17
    Kiya_17 (27)
    Verbringt hier viel Zeit
    1.204
    121
    1
    vergeben und glücklich
    Ich glaub der Name des Titels bezieht sich auf den blauen Balken am Browser? Ich bin zwar kein Experte was das angeht, aber ich bild mir ein vor ein paar Jahren hab ich das so gelernt...
     
    #2
    Kiya_17, 22 April 2008
  3. BenNation
    BenNation (33)
    Meistens hier zu finden Themenstarter
    1.225
    133
    74
    vergeben und glücklich
    Der Titel hat damit rein gar nix zu tun...
     
    #3
    BenNation, 22 April 2008
  4. Kiya_17
    Kiya_17 (27)
    Verbringt hier viel Zeit
    1.204
    121
    1
    vergeben und glücklich
    Mh ok.. war nur eine Vermutung und ich hab kaum Ahnung davon. Tut leid.
     
    #4
    Kiya_17, 22 April 2008
  5. BeowulfOF
    BeowulfOF (35)
    Verbringt hier viel Zeit
    314
    103
    11
    Single
    Ich kenn mich in PHP zwar auch nur sehr bedingt aus, aber ich glaube du musst den Inhalt der Variable erst mittels

    auslesen. In deinem Code sähe das dann so aus:

    Viel Erfolg

    MFG BeowulfOF
     
    #5
    BeowulfOF, 22 April 2008
  6. BenNation
    BenNation (33)
    Meistens hier zu finden Themenstarter
    1.225
    133
    74
    vergeben und glücklich
    cool, deine Aussage stimmt mit der eines anderen Forums überein^^

    Dann werde ich das so morgen mal testen! Danke vorerst!
     
    #6
    BenNation, 22 April 2008
  7. User 64931
    User 64931 (34)
    Verbringt hier viel Zeit
    745
    113
    81
    Verheiratet
    Wie Beowulf schon sagte, musst du das mittels GET auslesen, aber soweit ich weiß statt " musst du ' nehmen, also

    $_GET['user']
     
    #7
    User 64931, 22 April 2008
  8. User 76250
    Planet-Liebe Berühmtheit
    3.193
    348
    3.050
    Single
    Das ist Jacke wie Hose.
    Allerdings ist ' sauberer, denn wenn man " in einem Echo verwenden will, z.B.

    müsste dem " ein \ vorangesetzt werden, ergo:

    Wegen besserer Lesbarkeit ist es also besser, sich an das ' zu gewöhnen.
     
    #8
    User 76250, 22 April 2008
  9. BenNation
    BenNation (33)
    Meistens hier zu finden Themenstarter
    1.225
    133
    74
    vergeben und glücklich
    Soweit ich weiss, läuft das so:

    Okay, was Zuweisung betrifft, ist " und ' dasselbe, soweit ich weiss, aber

    $name="Ben"
    echo "Dein Name ist $name" = "Dein Name ist Ben"

    und

    echo 'Dein Name ist $name' = 'Dein Name ist $name'

    Die Interpretation von Variablen ist anders.


    edit: YES! Alles funzt soweit! Danke an BeowulfOF und die anderen.
     
    #9
    BenNation, 22 April 2008

jetzt kostenlos registrieren und hier antworten
Die Seite wird geladen...

Ähnliche Fragen - PHP Problem
BenNation
Musik, Filme, Computer und andere Medien Forum
21 Juli 2008
5 Antworten
BenNation
Musik, Filme, Computer und andere Medien Forum
30 Juni 2008
15 Antworten
snake_vn
Musik, Filme, Computer und andere Medien Forum
9 Juni 2007
3 Antworten