Willkommen auf Planet-Liebe

diskutiere über Liebe, Sex und Leidenschaft und werde Teil einer spannenden Community! :)

jetzt registrieren

suche formel in openoffice (bzw. excel)

Dieses Thema im Forum "Musik, Filme, Computer und andere Medien" wurde erstellt von Sokrates, 7 Oktober 2003.

  1. Sokrates
    Gast
    0
    nachdem ich nun schon seit geraumer zeit trial-and-error angewndet hab reichts mir, vielleicht kann mir ja wer von euch helfen.

    folgende situation:

    ich habe eine spalte (A), in deren zellen steht entweder "P" oder "S" - dann habe ich eine weitere spalte (B), deren zellen entweder leer sind oder nicht.

    problem:

    ich möchte die summe der zeilen, in denen der eintrag in A "P" ist und der eintrag in B nicht leer ist. die entsprechende summe, wenn der eintrag in A "S" ist.

    wie zum teufel krieg ich das hin? hauptproblem ist, daß ich ja über einen bereich arbeite, jeweils aber auf eine einzelnde zelle bezug nehmen muß.

    wär super, wenn jemand ne lösung weiß.

    greetz
     
    #1
    Sokrates, 7 Oktober 2003
  2. Mr. Poldi
    Verbringt hier viel Zeit
    3.068
    121
    0
    vergeben und glücklich
    Für Excel müsste folgendes funktionieren (aber frag nicht wie man darauf kommt ...):

    =SUMMENPRODUKT((A1:A500="P")*(B1:B500<>""))

    bzw.

    =SUMMENPRODUKT((A1:A500="S")*(B1:B500<>""))

    Das liefert die die Anzahl Zeilen in denen Spalte A=P oder S und Spalte B nicht leer ist.
    Die Range (Ax:Ay bzw. By:By) musst du halt anpassen.

    War es das was du wolltest?
     
    #2
    Mr. Poldi, 7 Oktober 2003
  3. Sokrates
    Gast
    0
    ich denke, das könnte es sein - funktioniert nur leider in openoffice nicht. es kann z.b. A1:A500="P" nicht ausgewertet werden, bereichsangaben werden nicht angenommen.

    trotzdem danke,

    greetz
     
    #3
    Sokrates, 7 Oktober 2003
  4. Mr. Poldi
    Verbringt hier viel Zeit
    3.068
    121
    0
    vergeben und glücklich
    Hmm ... also bei mir funktioniert das auch mit OOo 1.0.1.
    Du musst allerdings beim eingeben Strg-Shift-Enter drücken, mit Enter allein funktioniert es nicht.
     
    #4
    Mr. Poldi, 8 Oktober 2003
  5. Sokrates
    Gast
    0
    ah, prima, nun funktionierts, danke! :smile:

    greetz
     
    #5
    Sokrates, 8 Oktober 2003

jetzt kostenlos registrieren und hier antworten
Die Seite wird geladen...

Ähnliche Fragen - suche formel openoffice
LULU1234
Musik, Filme, Computer und andere Medien Forum
2 Dezember 2016 um 15:56
4 Antworten
RiaSommer
Musik, Filme, Computer und andere Medien Forum
30 Oktober 2016
6 Antworten
Test